Pengenalan
Group Policy Object (GPO)
Group Policy Object (GPO) adalah alat bantu yang dapat digunakan
untuk mengantur keamanan dan beberapa kebijakan di dalam platform Microsoft Windows. Alat bantu ini dapat
digunakan untuk memperketat konfigurasi keamanan dalam sistem – sistem yang
menjalankan sistem operasi windows dari
mulai versi Windows 2000, Windows XP,
Windows Server 2003, Windows Vista,
maupun Windows Server 2008.
Group Policy Object telah
terintegrasi dengan layanan Active
Directory untuk menyederhanakan konfigurasi dan manajemen sistem – sistem
melalui jaringan yang luas, dan mencakup beberapa pilihan konfigurasi metode
autentikasi, pengauditan sistem, pencatatan kejadian, pengaturan password, pengaksesan registry, enkripsi IPSec, dan masih
banyak konfigurasi lainnya.
Fungsi Group Policy
Object
Group Policy Object sering
digunakan untuk membatasi tindakan – tindakan tertentu yang menimbulkan resiko
keamanan potensial, seperti :
Ø Untuk
memblokir akses ke Task Manager
Ø Memblokir
akses ke suatu situs website tertentu
Ø Membatasi
akses ke direktori tertentu
Ø Menonaktifkan
file executable
Ø Mengatur
hak akses user di suatu group
Ø Memanajemen
suatu group
Pengenalan FTP
File
Transfer Protocol (FTP) pertama kali ditulis oleh Abhay Bhushan dan
diterbitkan sebagai RFC 114 pada tanggal 16 April tahun 1971 dan kemudian
digantikan oleh RFC 765 (Juni 1980) dan RFC 959 (Oktober 1985), spesifikasi
saat ini. Beberapa standar yang diusulkan mengubah RFC 959, misalnya RFC 2228
(Juni 1997) mengusulkan ekstensi keamanan dan RFC 2428 (September 1998)
menambahkan dukungan untuk IPv6 dan mendefinisikan tipe baru mode pasif.
Pada awalnya FTP adalah sebuah aplikasi yang
masih beroperasi dengan aplikasi aplikasi command-line
sebelum komputer memiliki Sistem Operasi dengan tampilan grafik seperti
sekarang ini. Dan mada masa itu aplikasi FTP Client ini hanya bisa digunakan
bersamaan dengan sistem operasi Windows,
Linux, dan Unix.
Namun sekarang ini telah banyak sekali alat dan aplikasi modern yang telah memungkinkan FTP bisa diakses dengan berbagai perangkat seperti desktop, server, piranti keras (hardware), dan bahkan perangkat seluler. Dan juga sekarang ini FTP telah bisa digunakan dengan memakai berbagai aplikasi yang jumlahnya mencapai ratusan aplikasi
Namun sekarang ini telah banyak sekali alat dan aplikasi modern yang telah memungkinkan FTP bisa diakses dengan berbagai perangkat seperti desktop, server, piranti keras (hardware), dan bahkan perangkat seluler. Dan juga sekarang ini FTP telah bisa digunakan dengan memakai berbagai aplikasi yang jumlahnya mencapai ratusan aplikasi
Pengertian FTP
FTP
adalah File Transfer Protocol
jaringan standar yang digunakan untuk mentransfer file dari satu host ke host
lain melalui jaringan berbasis TCP, seperti theInternet. FTP dibangun pada
arsitektur client-server dan menggunakan kontrol terpisah dan koneksi data
antara klien dan server. Pengguna FTP dapat mengotentikasi sendiri menggunakan
teks yang jelas untuk sign-in protokol tetapi dapat terhubung secara anonim
jika server dikonfigurasi untuk mengijinkankan hal tersebut.
Fungsi
FTP
Fungsi FTP adalah melakukan transfer file antara komputer yang
terhubung melalui jaringan, termasuk Internet. Dalam bahasa teknis, FTP dikenal
sebagai protokol jaringan yang memungkinkan transfer file antara komputer yang
tersambung pada TCP/IP yang berbasis jaringan. Hal Ini mencakup serangkaian
peraturan dan prosedur untuk transfer data digital yang aman.
Fungsi FTP lainnya adalah otentikasi dan kesalahan
penanganan teknik untuk membangun koneksi antara komputer host dan klien untuk
pertukaran data. Demikian pula Hyper Text
Transfer protocol (HTTP), menangani transfer halaman web dari server ke
komputer klien
Dalam menjalankannya FTP dibagi menjadi dua yaitu :
Ø FTP
Server
File Transfer Protokol
(FTP) Server adalah sebuah perangkat lunak yang bertanggung jawab untuk
menerima permintaan protokol FTP dari klien. Protokol FTP berfungsi untuk
mengunduh atau mengunggah file anta computer (Schering, Gotangco, & Ottina,
2010). Protokol FTP menggunakan protokol TCP untuk membentuk sesi komunikasi
awal sebelum melakukan transfer data. Server yang menjalankan FTP akan
mendengarkan percobaan koneksi dari klien pada port 21 (FTP control)
hingga sebuah koneksi terbentuk. Setelah koneksi terbentuk Server akan membuka
port 20 (FTP data) untuk melakukan transfer data antar server dan
klien.
Ø FTP
Client
FTP
Client merupakan aplikasi yang digunakan untuk mengelola dan mentransfer file
antara FTP Client dengan FTP Server FTP Client umumnya digunakan untuk
mengunduh maupun mengunggah file ke FTP Server. FTP Client berjalan berdasarkan
perotokol TCP untuk membentuk sesi koneksi awal sebelmum melakukan unggah
maupun unduh file. Adapun beberapa applikasi FTP Client diantaranya Filezilla,
FireFTP, WinSCP, Cyberduck dan lain-lain.
Saat
mentransfer data melalui jaringan, ada empat bentuk data yang dapat digunakan,
sebagai berikut :
Ø ASCII,
Digunakan untuk teks. Data diubah bentuknya sebelum pengiriman data dilakukan,
kemudian setelah diubah lalu dikirimkan dalam bentuk "8-bit ASCII".
Setelah data terkirim kepada penerima maka akan kembali diubah bentuknya.
Akibatnya, cara ini tidak bisa digunakan untuk pengiriman file yang berisi data
selain teks biasa.
Ø GAMBAR, Mesin
pengirim akan mengirimkan data gambar byte demi byte, dan penerima menyimpan
bytestream persis sama seperti saat menerimanya. (Mode foto telah
direkomendasikan untuk semua implementasi FTP).
Ø EBCDIC, Merupakan
pengiriman teks biasa antar host dengan menggunakan karakter EBCDIC. Mode ini
bentuknya seperti mode ASCII.
Ø LOKAL, Memungkinkan
dua komputer dengan settingan yang sama mengirim data dalam format yang
sebenarnya tanpa perlu mengubahnya menjadi ASCII.
haduh ateng makasih ya infonya
BalasHapus